aboutsummaryrefslogtreecommitdiffstats
path: root/ChangeLog
diff options
context:
space:
mode:
authorAndreas Schwab <schwab@suse.de>2018-07-18 17:30:19 +0200
committerAndreas Schwab <schwab@suse.de>2018-09-24 10:23:10 +0200
commit462d348caa16843594d8f23170ba7b635d2df220 (patch)
tree07f64fa4ba62cd684a76b9103a3fb281d73b920b /ChangeLog
parentf0458cf4f9ff3d870c43b624e6dccaaf657d5e83 (diff)
downloadtermbaud-462d348caa16843594d8f23170ba7b635d2df220.tar.gz
termbaud-462d348caa16843594d8f23170ba7b635d2df220.tar.xz
termbaud-462d348caa16843594d8f23170ba7b635d2df220.zip
Don't build libnsl for new ABIs
For architectures and ABIs that are added in version 2.29 or later the option --enable-obsolete-nsl is no longer available, and no libnsl compatibility library is built.
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog18
1 files changed, 18 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 55214c32764..81e58df2c54 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,21 @@
+2018-09-24 Andreas Schwab <schwab@suse.de>
+
+ * scripts/haveversions.awk: New file.
+ * Makerules ($(common-objpfx)Versions.def)
+ ($(common-objpfx)Versions.all, $(common-objpfx)Versions.v.i)
+ ($(common-objpfx)sysd-versions, $(common-objpfx)versions.stmp):
+ Move rules ...
+ * Makeconfig ($(common-objpfx)Versions.def)
+ ($(common-objpfx)Versions.all, $(common-objpfx)Versions.v.i)
+ ($(common-objpfx)sysd-versions, $(common-objpfx)versions.stmp):
+ ... here.
+ ($(common-objpfx)Versions.mk): New rule. Include it.
+ * nis/Makefile [!have-GLIBC_2.28]: Don't build any targets.
+ Emit error if build-obsolete-nsl = yes.
+ * manual/install.texi (Configuring and compiling): Describe
+ --enable-obsolete-nsl as unavaiable after version 2.28.
+ * INSTALL: Regenerate.
+
2018-09-21 Adhemerval Zanella <adhemerval.zanella@linaro.org>
* NEWS: Add note about new TLE support on powerpc64le.