aboutsummaryrefslogtreecommitdiffstats
path: root/sound/pci
diff options
context:
space:
mode:
authorTakashi Iwai <tiwai@suse.de>2010-11-26 17:11:18 +0100
committerTakashi Iwai <tiwai@suse.de>2010-11-26 17:11:18 +0100
commit5a8cfb4e8ae317d283f84122ed20faa069c5e0c4 (patch)
tree9d5fc243a1721406bfe2624d2285f4f842eee14c /sound/pci
parent7167594a3da7dcc33203b85d62e519594baee390 (diff)
downloadmrst-s0i3-test-5a8cfb4e8ae317d283f84122ed20faa069c5e0c4.tar.gz
mrst-s0i3-test-5a8cfb4e8ae317d283f84122ed20faa069c5e0c4.tar.xz
mrst-s0i3-test-5a8cfb4e8ae317d283f84122ed20faa069c5e0c4.zip
ALSA: hda - Use ALC_INIT_DEFAULT for really default initialization
When SKU assid gives no valid bits for 0x38, the driver didn't take any action, so far. This resulted in the missing initialization for external amps, etc, thus the silent output in the end. Especially users hit this problem on ALC888 newly since 2.6.35, where the driver doesn't force to use ALC_INIT_DEFAULT any more. This patch sets the default initialization scheme to use ALC_INIT_DEFAULT when no valid bits are set for SKU assid. Reference: https://bugzilla.redhat.com/show_bug.cgi?id=657388 Reported-and-tested-by: Kyle McMartin <kyle@redhat.com> Cc: <stable@kernel.org> Signed-off-by: Takashi Iwai <tiwai@suse.de>
Diffstat (limited to 'sound/pci')
-rw-r--r--sound/pci/hda/patch_realtek.c1
1 files changed, 1 insertions, 0 deletions
diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
index 81a2a49b862..886d7c72936 100644
--- a/sound/pci/hda/patch_realtek.c
+++ b/sound/pci/hda/patch_realtek.c
@@ -1614,6 +1614,7 @@ do_sku:
spec->init_amp = ALC_INIT_GPIO3;
break;
case 5:
+ default:
spec->init_amp = ALC_INIT_DEFAULT;
break;
}