aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorTetsuo Handa <penguin-kernel@I-love.SAKURA.ne.jp>2010-10-08 14:43:22 +0900
committerJames Morris <jmorris@namei.org>2010-10-21 10:12:45 +1100
commit9f1c1d426b0402b25cd0d7ca719ffc8e20e46d5f (patch)
tree5d31ff027688a90cef5ccea5bee1cb3e65639b37 /security
parentb0ae19811375031ae3b3fecc65b702a9c6e5cc28 (diff)
downloadmrst-s0i3-test-9f1c1d426b0402b25cd0d7ca719ffc8e20e46d5f.tar.gz
mrst-s0i3-test-9f1c1d426b0402b25cd0d7ca719ffc8e20e46d5f.tar.xz
mrst-s0i3-test-9f1c1d426b0402b25cd0d7ca719ffc8e20e46d5f.zip
TOMOYO: Print URL information before panic().
Configuration files for TOMOYO 2.3 are not compatible with TOMOYO 2.2. But current panic() message is too unfriendly and is confusing users. Signed-off-by: Tetsuo Handa <penguin-kernel@I-love.SAKURA.ne.jp> Reviewed-by: KOSAKI Motohiro <kosaki.motohiro@jp.fujitsu.com> Signed-off-by: James Morris <jmorris@namei.org>
Diffstat (limited to 'security')
-rw-r--r--security/tomoyo/common.c11
1 files changed, 10 insertions, 1 deletions
diff --git a/security/tomoyo/common.c b/security/tomoyo/common.c
index e0a1059aaf3..7556315c197 100644
--- a/security/tomoyo/common.c
+++ b/security/tomoyo/common.c
@@ -2053,13 +2053,22 @@ void tomoyo_check_profile(void)
const u8 profile = domain->profile;
if (tomoyo_profile_ptr[profile])
continue;
+ printk(KERN_ERR "You need to define profile %u before using it.\n",
+ profile);
+ printk(KERN_ERR "Please see http://tomoyo.sourceforge.jp/2.3/ "
+ "for more information.\n");
panic("Profile %u (used by '%s') not defined.\n",
profile, domain->domainname->name);
}
tomoyo_read_unlock(idx);
- if (tomoyo_profile_version != 20090903)
+ if (tomoyo_profile_version != 20090903) {
+ printk(KERN_ERR "You need to install userland programs for "
+ "TOMOYO 2.3 and initialize policy configuration.\n");
+ printk(KERN_ERR "Please see http://tomoyo.sourceforge.jp/2.3/ "
+ "for more information.\n");
panic("Profile version %u is not supported.\n",
tomoyo_profile_version);
+ }
printk(KERN_INFO "TOMOYO: 2.3.0\n");
printk(KERN_INFO "Mandatory Access Control activated.\n");
}